Selenium IDE Failing to on Firefox Browser!! Need some help.

Posted by Anishaticzon under JavaScript on 7/7/2012 | Points: 10 | Views : 741 | Status : [Member] | Replies : 1
I am trying to run selenium test cases on my site and getting a wierd firefox launching problem from past few days.

I have tried few options per selenium FAQ page, however the problem still persists.
I have tried following things

1. I have tried cleaning up the C:\DOCUME~1\fromdev\LOCALS~1\Temp directory. The directory mentioned in the java stacktrace does not really exist on my system.
2. I have also tried restarting my system, just avoid any existing processes causing this.
3. I have also tried checking the task manager on my windows machine and I dont see any firefox processes.
4. I have also tried removing existing firefox profiles and recreating them.
5. I have also tried firefox with no-addon mode, however no difference.

The exception stacktrace is as shown below.

12:06:54.218 INFO - creating new remote session
12:06:54.218 INFO - Allocated session 6461092698d344f0b9856f9152024b63 for, launching...
12:06:54.234 INFO - Preparing Firefox profile...
12:07:15.238 ERROR - Failed to start new browser session, shutdown browser and clear all session data
java.lang.RuntimeException: Firefox refused shutdown while preparing a profile
at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.wai
at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.pop
at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.lau
at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.lau
at org.openqa.selenium.server.browserlaunchers.FirefoxLauncher.launchRem
at org.openqa.selenium.server.BrowserSessionFactory.createNewRemoteSessi
at org.openqa.selenium.server.BrowserSessionFactory.getNewBrowserSession
at org.openqa.selenium.server.BrowserSessionFactory.getNewBrowserSession
at org.openqa.selenium.server.SeleniumDriverResourceHandler.getNewBrowse
at org.openqa.selenium.server.SeleniumDriverResourceHandler.doCommand(Se
at org.openqa.selenium.server.SeleniumDriverResourceHandler.handleComman
at org.openqa.selenium.server.SeleniumDriverResourceHandler.handle(Selen
at org.openqa.jetty.http.HttpContext.handle(
at org.openqa.jetty.http.HttpContext.handle(
at org.openqa.jetty.http.HttpServer.service(
at org.openqa.jetty.http.HttpConnection.service(

at org.openqa.jetty.http.HttpConnection.handleNext(
at org.openqa.jetty.http.HttpConnection.handle(
at org.openqa.jetty.http.SocketListener.handleConnection(SocketListener.
at org.openqa.jetty.util.ThreadedServer.handle(
at org.openqa.jetty.util.ThreadPool$
Caused by: org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher$FileLockRemainedException: Lock file still present! C:\DOCUME~1\fromdev\LOCALS~1\Temp\customProfileDir6461092698d344f0b9856f9152024b63\parent.lock
at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.wai
at org.openqa.selenium.server.browserlaunchers.FirefoxChromeLauncher.wai
... 20 more
12:07:15.238 INFO - Got result: Failed to start new browser session: Error while
launching browser on session null


Posted by: Peermohamedmydeen on: 7/9/2012 [Member] Bronze | Points: 25

Have you tried with upgrade / downgrade of your firefox instance? It could be the bug in firefox to be launched remotely. Did you update your firefox in recent days? What is your firefox version?

Anishaticzon, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response