Server Application Unavailable

Posted by Sunitajadhav under IIS on 1/27/2010 | Views : 5226 | Status : [Member] | Replies : 3
Hello friends,
I have done web application in .net framework 2.0 and now i converted into .net framework 3.5.So i published my web application in .net 3.5 framework.It is successfully published.But when i browse the home page from virtual directory in IIS so i got the following error.
what should i do now?
Thanks in advance.

Server Application Unavailable

The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.



Posted by: Abhi2434 on: 1/27/2010 [Member] [Microsoft_MVP] [MVP] Silver

Do you have .NET framework 3.5 installed in the server computer. 3.5 actually comes as a patch to 2.0 with few updates to the dlls in GAC.

Just make sure the framework is properly installed, also it is better to have separate application pool area for applications running on different versions of framework.
Create an application pool for the application, and assign it to your 3.5 application, and see if it solves the issue or not.

If this doesnt solves, reinstall by going to Visual Studio command prompt and run

aspnet_regiis /i

This should cure the problem, still have problem, it should be the problem with your code. Use Remote debugging to debug your application running in IIS.
Use this article to know how you can debug your application remotely :

I am sure this will solve it.

Sunitajadhav, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Nishithraj on: 1/27/2010 [Member] Bronze

Whether you have selected the right framework in the IIS server.

Mark this as answer, if it is.....

With regards
Nishithraj Narayanan

Sunitajadhav, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Gttejas on: 3/19/2010 [Member] Starter


I think you have installed framework later than the iis.So, you need to register framework in iis.

you can do this by
aspnet_regiis -i

Please follow the following step

1. Stops the IIS and the ASP.NET state services.

2.Deletes and then re-creates the ASPNET account by using a known temporary password.
3.Uses the Windows runas command to start an executable that creates an ASPNET user profile.
An ASPNET user profile works around the issue.

3.Reregisters ASP.NET. (using aspnet_regiis.exe from visual studio command propmt.)
This step creates a new random password for the account and applies default ASP.NET access control settings for the account.
4.Restarts the Microsoft Internet Information Services (IIS) service.
5.give rights to ASPNET user as well as Workprocess user to your application root folder.

Will reslove your problem.

Let me know if you get any problem immediately.

You can also mail me personaly on

Sunitajadhav, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response