The maximum message size quota for incoming messages (65536) has been exceeded. To increase the quot [Resolved]

Posted by Rickeybglr under WCF on 3/26/2013 | Points: 10 | Views : 4615 | Status : [Member] | Replies : 2
I am getting this error while running service.
here is my config setting:
<services>
<service name="TestService">
<endpoint address="http://localhost:60157/TestService.svc" binding="basicHttpBinding" contract="ITest" bindingConfiguration= "BasicHttpBinding_ITest" ></endpoint>
<endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange" />
</service>
</services>
<bindings>
<basicHttpBinding>
<binding name="BasicHttpBinding_ITest" closeTimeout="00:10:00" openTimeout="00:10:00"
sendTimeout="00:10:00" maxBufferPoolSize="2147483647" maxBufferSize="2147483647"
maxReceivedMessageSize="2147483647">
<readerQuotas maxArrayLength="2147483647" maxNameTableCharCount="2147483647"
maxStringContentLength="2147483647" maxDepth="2147483647"
maxBytesPerRead="2147483647" />
<security mode="None">
<transport clientCredentialType="None" proxyCredentialType="None" realm="" />
<message clientCredentialType="UserName" algorithmSuite="Default" />
</security>
</binding>
</basicHttpBinding>
</bindings>

i also tried with the value 20000000, still getting the same error.




Responses

Posted by: Sandeepmhatre on: 3/26/2013 [Member] Starter | Points: 50

Up
0
Down

Resolved
my problem solved with this ,
maxReceivedMessageSize="20000000"

Try to limit your dataset size. preferably add some kind of filter parameter while hitting to database.



Sandeep M,
Software Developer
Follow me on :
http://sandeepmhatre.blogspot.in

Rickeybglr, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Rickeybglr on: 3/26/2013 [Member] Starter | Points: 25

Up
0
Down
Yes Sandeep, i found the solution ur rite we need to limit the size of dataset ..thanks

Rickeybglr, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response