SAP crystal reports Load report failed error after deploying

Posted by Sampath1750 under ASP.NET on 7/19/2013 | Points: 10 | Views : 2986 | Status : [Member] | Replies : 1
Hi all,

My application is running in production which developed in Asp.net 4.0 and reports are in crystal Report 13. the back end is sql server 2008, i am constanly facing the problem that Load Report Failed. Once i restart the IIS website, the problem is rectified. we are unable to identify whether this problem due to application bug or missing configuration in any IIS setting. Could any one help us to reslove this problem?


btnSubmit_click Load report failed.
System.Runtime.InteropServices.COMException (0x80000000): The maximum report processing jobs limit configured by your system administrator has been reached.
at CrystalDecisions.ReportAppServer.ClientDoc.ReportClientDocumentClass.Open(Object& DocumentPath, Int32 Options) at
CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.Open(Object& DocumentPath, Int32 Options) at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.
EnsureDocumentIsOpened() CrystalDecisions.CrystalReports.Engine at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened()
at CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename, OpenReportMethod openMethod, Int16 parentJob) at
CrystalDecisions.CrystalReports.Engine.ReportClass.Load(String reportName, OpenReportMethod openMethod, Int16 parentJob) at CrystalDecisions.CrystalReports.Engine.
ReportDocument.EnsureLoadReport() at CrystalDecisions.CrystalReports.Engine.ReportDocument.SetDatabaseLogon(String user, String password) at Project Loactaion.aspx.cs:line 111

i searched in google, i got below sollution, but problem not fixed.
click run -> regedit ->
HKEY_LOCAL_MACHINE\SOFTWARE\SAP BUSINESSOBJECTS\CRYSTAL REPORTS FOR .NET FRAMEWORK 4.0\REPORT APPLICATION SERVER\IN PROC SERVER\PrintJobLimit changed 75 to -1.

Thanks




Responses

Posted by: Jitendrasoft09 on: 7/19/2013 [Member] [MVP] Starter | Points: 25

Up
0
Down
Hi Sampath,

It might be the issue of regestring your asp.net on IIS, make sure you have to register first then you reset.

Use below code to register and reset on IIS

aspnet_regiis -i 

iisreset /start


Hope you are clear..

Jitendra Kumar
If my post helps you, plz mark as an answer.

Sampath1750, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response