Sql Server 2012 Express is eating up all the memory of my server

Posted by Sheonarayan under Error and Solution on 7/24/2013 | Points: 10 | Views : 3223 | Status : [Administrator] | Replies : 2

Yes, this can happen. One of the user complained that despite SQL Server Express 2012 has limitation of 1GB RAM, its consuming even more.

I noticed that in my server when the SQL Server express 2012 starts, it works with the minimal memory but as the time progresses, it starts consuming more and more memory (I also noticed that the performance of the database decreases). To overcome the problem we need to set the limitation on the memory consumption by the SQL Server 2012 Express. To do that follow below steps

1. Opne SQL Server Management Studio.
2. Right click the server and select Properties.
3. Click on Memory from left panel on the dialogue box.
4. Change the value of Maximum server memory (in MB) to something like 600, 800 or whatever you can afford to spend for SQL Server based on the amount of RAM have in your server
5. Click OK

and you are done. Now check your application that is using this database and you will notice slight improvement (at least I noticed). I also noticed that other application running on the server also starts performing well.


Sheo Narayan


Posted by: Jitendrasoft09 on: 7/24/2013 [Member] [MVP] Starter | Points: 25

Hi Sheo,

I have not installed the Sql Server 2012 yet. Once I will install the Sql Server, really this information would be helpful for me.

Thanks for sharing new information about Sql Server 2012.

Jitendra Kumar
If my post helps you, plz mark as an answer.

Sheonarayan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Pandians on: 7/24/2013 [Member] [MVP] Silver | Points: 25

Yeah Correct and Thanks Sheo!

I would like to remind something about configuring/Minimizing the memory by changing the "Max Server Memory" option

SQL Server performance may be reduced Incase our request needs more memory then the comfiguration Or SQL Server starting also may be prevented!


Our new request has to wait till the previous process complets! So, You may be experiencing slow response Or Keep on running even for simple request!

So, Please don't configure low memory :)

iLink Multitech Solutions

Sheonarayan, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response