How to disable the network authentication in my website?

Posted by Prabu_Spark under ASP.NET on 10/10/2013 | Points: 10 | Views : 949 | Status : [Member] | Replies : 1
Hi sir,
I create one website, which plays audio file in gridview , i store that audio files in the server d drive of 192.168.100.4\Recording folder . If i run my application, it is asking for usename and password to display the audio file in gridview.


[Note: If i run the website having gridview containing audio files, it is asking for authentication, how to remove that authentication. I stored the audio files in another machine, so it is asking for authenticatin everytime i run the code]

I attached the screenshot and code for your reference. Kindly give me the solution for this problem.



Web.config:
================

<?xml version="1.0"?>
<configuration>
<appSettings/>
<connectionStrings>
<add name="ConnectionString" connectionString="Data Source=localhost;user id=sa;password=god;Integrated Security=false;Initial Catalog=checking" providerName="System.Data.SqlClient"/>
</connectionStrings>
<system.web>

<compilation debug="true">
</compilation>

<authentication mode="Forms">
<forms loginUrl="~/Login.aspx" timeout="8000"></forms>
</authentication>

</system.web>
</configuration>


Default.aspx
=================

<asp:GridView ID="GridView1" runat="server" AutoGenerateColumns="False">
<Columns>
<asp:BoundField DataField="CalledDate" HeaderText="CalledDate" />
<asp:BoundField DataField="Callerid" HeaderText="Callerid" />
<asp:BoundField DataField="StartDate" HeaderText="StartDate" />
<asp:BoundField DataField="EndDate" HeaderText="EndDate" />
<asp:BoundField DataField="Duration" HeaderText="Duration" />
<asp:BoundField DataField="filename3" HeaderText="filename3" />

<asp:TemplateField HeaderText="PLAY">
<ItemTemplate>
<object classid="clsid:22D6F312-B0F6-11D0-94AB-0080C74C7E95" height="45" width="75"
id="Object1">
<param name="AutoStart" value="0" />
<param name="FileName" value='http://192.168.100.4//Recording//<%# Eval("filename3") %>' />

</object>
</ItemTemplate>
<ItemStyle Wrap="True" />
</asp:TemplateField>
</Columns>
</asp:GridView>

With regards,
J.Prabu.
[Email:prbspark@gmail.com]



Responses

Posted by: Bandi on: 10/11/2013 [Member] [MVP] Platinum | Points: 25

Up
0
Down
Refer
http://stackoverflow.com/questions/53464/how-to-stop-iis-asking-authentication-for-default-website-on-localhost
http://stackoverflow.com/questions/2713192/disable-authentication-on-subfolders-of-an-asp-net-app-using-windows-authentic
http://forums.iis.net/t/1199020.aspx

Mark This Response as Answer
--
Chandu
http://www.dotnetfunda.com/images/dnfmvp.gif

Prabu_Spark, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response