Authentication asked while debugging any Project in Visual Studio 2013

Posted by Raj.Trivedi under Visual Studio on 9/14/2014 | Points: 10 | Views : 534 | Status : [Member] [MVP] | Replies : 1
Hello Team,

I have installed VS 2013 and i created a new project which has windows authentication enabled and Anonymous authentication disabled.

My Operating system is Windows 7 and does not have password for user account and the user account has administrator rights.

Now when i am trying to debug or run any webform project or webform site i am being asked for username and password.

I am pasting my webconfig file below... Have a look any suggestions will be appreciated

Web Config

<?xml version="1.0"?>

For more information on how to configure your ASP.NET application, please visit


<add name="cnnLocal1" connectionString="Data Source=.;Initial Catalog=SSDCLive;Persist Security Info=True;User ID=sa;Password=sqluser" providerName="System.Data.SqlClient"/>
<add name="cnnLocal2" connectionString="Data Source=SHREE-PC\SQLEXPRESS;Initial Catalog=POPL;Persist Security Info=True;User ID=sa;Password=admin123" providerName="System.Data.SqlClient"/>
<compilation debug="true" targetFramework="4.5.1" />
<httpRuntime targetFramework="4.5.1" />


"Sharing is Caring"
Please mark as answer if your Query is resolved


Posted by: Sheonarayan on: 9/15/2014 [Administrator] HonoraryPlatinum | Points: 25

In above web.config, there is no setting for Authentication. In any case because you have enabled windows authentication, it should ask fro username and password. If you do not have, leave the password blank and enter Enter (but keep the username).

This should work.

Sheo Narayan

Raj.Trivedi, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response