SSRS report permission is not working properly

Posted by Santosh4u under Sql Server on 7/31/2016 | Points: 10 | Views : 85 | Status : [Member] | Replies : 0
hi i am working on SSRS report and all my reports are go live now with all the user permission but not sure why permission is not working sometimes for some of the users.

As i know that i can set permission with 3 different ways.
1. Site level
2. folder Level
3. Report Level

whenever a new user comes in to browse the report, i follows the below to just browser the report.

Step: 1 opened the Reportmanager URL(http://toshiba-pc/Reports) and click Home
Step : 2 clicking on "Folder Settings"
Step 3: Click on "New Role Assignment" and enter the domainname\TestUser with "Browser" role and click "OK" will add TestUser user automatically to all the folder
problem : some of user is not appearing into all folders some of the user is appearing into all folders.

to avoid above problem, i added DomainName\TestUser into each folder security and it's again not appearing for all reports ,
so i have to check security for all the reports under this folder.

this is very difficult to go each report to check whether reports has permission or not?

really don't know why some of reports inside same folder is not working but some of reports are working where folder having the permission.

is there anything i am missing to configure , please let me know.
do i need to set role(system user, system administrator) for all the users to site setting. i never add user into site setting..

Please any one let me know what i am missing to configure.



(No response found.)

Login to post response