Browse shows empty screen after Hosting a website of visual studio 2012 with C# on IIS 7

Posted by Raiamit2527 under ASP.NET on 6/15/2017 | Points: 10 | Views : 171 | Status : [Member] | Replies : 0
Recently I have made a website on VS2012 with C# and after hosting it on IIS7 in Windows 7(32bit); unable to view website while browsing it “localhost refused to connect”.
For this I have applied following processes:
1. Check IIS->www services->Application Development Features-> Enable ASP.NET, ISAPI Exten and Filters
2. Publish my website as “File System” publish method successfully.
3. Cmd prompt cd %windir%\Microsoft.NET\Framework\V4.0.30319 press enter and then
asp_netregiis.exe –I –enable
4. Open IIS Manager as Admin, Right Click on Sites ->Add Website->Enter Site Name, Physical path, IP Address of My PC and change port to 10 (Since My PC connected through LAN)
On Click “Connect as…” I assign Username and password of my PC
5. In Application Pool of my website Set .NET framework to 4.0
6. Now I added Default document
I also tried these tricks
• Giving a host name as www.mysite.com and add it on C->Windows->System32->drivers->etc->hosts (open it in notepad) then write
127.0.0.1 www.mysite.com & save it.
• Also tried to host my website inside inetpub->wwwroot
• Impersonate in web.config, <identity impersonate="true" /> inside <System.web>
• Authentication in IIS of my site set Anonymous authentication Enable & Impersonation Enable
Pl help me.




Responses

(No response found.)

Login to post response