adrotator control - image file not displayed

Posted by Gayathri under ASP.NET on 2/1/2011 | Points: 10 | Views : 4809 | Status : [Member] | Replies : 3
is it a must that i should have a datasource to display images in adrotator control.

i am trying to add an ads.xml in my adrotator.
but it does not display the image at all.
thought the path of the image file in ads.xml must be wrong. but i have tried giving the full path of the image file also.

please follow the below code.

<ImageUrl>images/nokia.jpg</ImageUrl>
Displays no error. but does not display the image and the alternate text too.




Responses

Posted by: Prabhakar on: 2/1/2011 [Member] [MVP] Starter | Points: 25

Up
0
Down
Hi Gayathri ...

u write code this way . .

<ImageUrl>../images/nokia.jpg</ImageUrl>

Best Regard's
Prabhakar

Gayathri, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Karthikanbarasan on: 2/1/2011 [Member] [Moderator] [Microsoft_MVP] [MVP] Silver | Points: 25

Up
0
Down
Hi,

the xml shld be like below

Ad>
<ImageUrl>site1img1.jpg</ImageUrl>
<NavigateUrl>../images/nokia.jpg</NavigateUrl>
<Keyword>Product1</Keyword>
</Ad>

<Ad>
<ImageUrl>site2img2.jpg</ImageUrl>
<NavigateUrl>../images/nokia1.jpg</NavigateUrl>
<Keyword>Product2</Keyword>
</Ad>



Thanks
Karthik
www.f5Debug.net

Gayathri, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Gayathri on: 2/2/2011 [Member] Starter | Points: 25

Up
0
Down
Hi,

<Imageurl>~/images/nokia.jpg</Imageurl> this works.

To be accurate when i tried this from my laptop using vs.net 2010 version it works(along with google chrome as default browser).
but when i tried this with vs.net 2008 version it did not(iexplore as browser).


Is it a browser bug?? !!
please clarify

Gayathri, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response