Crystal Report Multiple copies of single report page? [Resolved]

Posted by Laghaterohan under Regular Expressions on 2/10/2011 | Points: 10 | Views : 12358 | Status : [Member] | Replies : 8
Hello,

I have a crystal report..to display some information...That information is only of 1 page. However, the same information span over multiple pages !! why is this happening?
Also, When i print the report i get multiple copies of the same report?? Please help me out....why is this happening?


Thanks!

Best Regards,
Rohan Laghate



Responses

Posted by: Laghaterohan on: 2/10/2011 [Member] Starter | Points: 25

Up
0
Down

Resolved
finally..its working....:)

what i did was placed both the sub reports in the Report footer !! :) and it worked....

seems my solution is rather wierd but its working as of now....


Thanks any ways ...all of you u helped me to approach towards my solution.

Best Regards,
Rohan Laghate

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: jayanthichebrolupanoramicworldbiz-8895 on: 2/10/2011 [Member] Starter | Points: 25

Up
0
Down
Hi,

Can u explain exactly in which section you placed the information.need some more information on this question.

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Laghaterohan on: 2/10/2011 [Member] Starter | Points: 25

Up
0
Down
Hi Jayanthi..

I have heading of the report in Page Header a section
In my Page Header b i have another information..

In Section 3 (Details a) i have a subreport
In Details Section 1 (Details b) i have another subreport


Then i have Page Footer and then Report footer....

Please help..


Best Regards,
Rohan Laghate

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Karthikanbarasan on: 2/10/2011 [Member] [Moderator] [Microsoft_MVP] [MVP] Silver | Points: 25

Up
0
Down
Hi,

Can you check if there is any extra margin over passing on to the other page

Thanks
Karthik
www.f5Debug.net

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: jayanthichebrolupanoramicworldbiz-8895 on: 2/10/2011 [Member] Starter | Points: 25

Up
0
Down
Here I am suggesting 2 reasons for you

1.One probelm is with the issue occurs in the Crystal Designer try to redesign the subreports parts again into fresh report designer
2.Another is To find where the problem may reside with incorrect data being
returned, you may want to eliminate the record selection, or the way the
database tables have been linked.
Remove the record selection one by one from your report to noting when
expected data is returned.

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Laghaterohan on: 2/10/2011 [Member] Starter | Points: 25

Up
0
Down
i redisgned the report and still the problem occurs...am going mad...i dont understand why is this problem occuring?

I have 2 subreports Credit and Debit....I have 2 tables returned....i bind the Credit table to the credit sub report and debit to the debit sub report!...

Basically i found out one thing that...if in my credit subreport there are 4 rows..my pages generated are 4...if there are 10 rows then my pages generated are 10...why is this happening?????

Best Regards,
Rohan Laghate

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: jayanthichebrolupanoramicworldbiz-8895 on: 2/10/2011 [Member] Starter | Points: 25

Up
0
Down
check in your report whether a field in any row(S) is too wide to fit on the page then you get a page extra to finish the right hand end of the field . Make sure the entire field fits on the page.


Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Karthikanbarasan on: 2/10/2011 [Member] [Moderator] [Microsoft_MVP] [MVP] Silver | Points: 25

Up
0
Down
Thats good...

Thanks
Karthik
www.f5Debug.net

Laghaterohan, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response