HTTP could not register URL http://xxx.svc Your process does not have access ri

Posted by SheoNarayan under Error and Solution on 2/15/2011 | Points: 10 | Views : 20928 | Status : [Administrator] | Replies : 3

I was getting following error while trying to host my WCF Service in the console application

HTTP could not register URL http://localhost:26584/Service1.svc Your process does not have access rights to this namespace (see http://go.microsoft.com/fwlink/?LinkId=70353 for details).

This cause of this error is that the Visual Studio and normal program runs in limited-rights. There are couple of solution of this problem

1. Register the WCF service address to your machine by calling following command from your command prompt (you need to run your command prompt as an Administrator)
netsh http add urlacl url=http://+:8000/ServiceModelSamples/Service user=mylocaluser


2. If you are trying to run your console app from Visual Studio, run VS as Administrator and then try to run the console app.

3. Right click the console app and select Run as Administrator

I hope this will help someone.

Regards,
Sheo Narayan
http://www.dotnetfunda.com



Responses

Posted by: Naimishforu on: 2/16/2011 [Member] [MVP] Bronze | Points: 25

Up
0
Down
Yeah..I have faced similar issue multiple times.

I ended doing this.'

I use Win 7, right clicked on on VS 2010 shortcut and selected the option.

Always Run as Administrator :D

Thanks

Thanks,
Naimish
http://dotnetinterview.zxq.net/
http://naimishpandya.blogspot.in/

SheoNarayan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Karthikanbarasan on: 2/16/2011 [Member] [Moderator] [Microsoft_MVP] [MVP] Silver | Points: 25

Up
0
Down
good one!!

Thanks
Karthik
www.f5Debug.net

SheoNarayan, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Naimishforu on: 2/16/2011 [Member] [MVP] Bronze | Points: 25

Up
0
Down
Yup, It got worked too...

Thanks,
Naimish
http://dotnetinterview.zxq.net/
http://naimishpandya.blogspot.in/

SheoNarayan, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response