connecting to a remote oracle database server using asp .net with c#

Posted by Lokeshbasana under ASP.NET on 4/2/2009 | Views : 7159 | Status : [Member] | Replies : 1
For local System I used this OLEDB connection to Oracle Database its working fine

<add key="ConnectionString" value="Provider=MSDAORA.1;Data Source=net;User ID=wings;Password=wings;Unicode=True"/>

when i was connecting to remote system it show error
Oracle client and networking components were not found. These components are supplied by Oracle Corporation and are part of the Oracle Version 7.3.3 or later client software installation.

how to connect to remote Oracle Database VIA IP
please send me the reply


Posted by: Vuyiswamb on: 4/2/2009 [Member] [MVP] [Administrator] NotApplicable

Good Day Lokeshbasana

Oracle 9.2 Client software requires that you give the Authenticated User
privilege to the Oracle Home by following these steps:

1. Log on to Windows as a user with Administrator privileges.

2. Launch Windows Explorer from the Start Menu and navigate to the
ORACLE_HOME folder. This is typically the "Ora92" folder under the
"Oracle" folder (i.e. D:\Oracle\Ora92).

3. Right-click on the ORACLE_HOME folder and choose the "Properties" option
from the drop down list. A "Properties" window should appear.

4. Click on the "Security" tab of the "Properties" window.

5. Click on "Authenticated Users" item in the "Name" list (on Windows XP
the "Name" list is called "Group or user names").

6. Uncheck the "Read and Execute" box in the "Permissions" list under the
"Allow" column (on Windows XP the "Permissions" list is called
"Permissions for Authenticated Users").

7. Re-check the "Read and Execute" box under the "Allow" column (this is
the box you just unchecked).

8. Click the "Advanced" button and in the "Permission Entries" list make
sure you see the "Authenticated Users" listed there with:

Permission = Read & Execute
Apply To = This folder, subfolders and files

If this is NOT the case, edit that line and make sure the "Apply onto"
drop-down box is set to "This folder, subfolders and files". This
should already be set properly but it is important that you verify this.

9. Click the "Ok" button until you close out all of the security properties
windows. The cursor may present the hour glass for a few seconds as it
applies the permissions you just changed to all subfolders and files.

10. Reboot your computer to assure that these changes have taken effect.

Re-execute the application and it should now work.

Thank you For Posting in .NETFUNDA

Were looking forward for your reply

Vuyiswa Maseko

Thank you for posting at Dotnetfunda

Lokeshbasana, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response