hope if i install dotnet frame work 4.0 - my existing asp.net3.5 projects wont get affected

Posted by Thiru under Others on 9/17/2011 | Points: 10 | Views : 1627 | Status : [Member] | Replies : 8
Hi,

i like to install dotnet frame work 4.0 for which i got this msg.:

Make sure that your computer has the latest Windows service pack and critical updates. To find security updates, visit Windows Update. If you are installing on XP 64 bit or Windows 2003 you might need to install the Windows Imaging Component. The Windows Imaging Component 32 bit can be found here . The Windows Imaging Component 64 bit can be found here .

my question is:
how to know whether i required 64bit or 32bit ?
and also, how to know whether i required windows imaging component or not ?
hope if i install dotnet frame work 4.0 - my existing asp.net3.5 projects wont get affected.




Responses

Posted by: SheoNarayan on: 9/18/2011 [Administrator] HonoraryPlatinum | Points: 25

Up
0
Down
Your existing project will not affect. In latest version of IIS or Visual Studio you have ability to target your website project on specific version.

Right click your My Computer icon and look at the details, you will come to know about machine bit.

Thank

Regards,
Sheo Narayan
http://www.dotnetfunda.com

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Thiru on: 9/18/2011 [Member] Starter | Points: 25

Up
0
Down
Thanks Sheo,
If we install, i may like to run my asp.net3.5 and 4.0 application separately.
i hope there is an option to select the version in IIS -- HOW TO DO THIS ?

And by right click on my computer icon i am getting the following details:
System:
Microsoft Windows XP
Porfessional
Version 2002
Service Pack 2

Computre:
Genuine Intel(R) CPU
T2060 @ 1.60GHz
798 MHz, 1.49 GB of RAM

With this information what i can able to know about installation of asp.net 4.0?
pls. provide little more...

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 9/18/2011 [Member] [MVP] [Administrator] NotApplicable | Points: 25

Up
0
Down
hi Thiru

in IIS7 there is an Applicationpool . this allows you to host application with different version of .net. So if you install .net 4 in a machine, it does not mean you have installed asp.net 4 in IIS. There are things you need to do . e.g

you must do this in command line

C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

and this will install asp.net 4 with bindings. now in the Application you must go to advanced settings to set the application pool , this is where you tell your website to use which version of iIS.

:)


Thank you for posting at Dotnetfunda
[Administrator]

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Thiru on: 9/18/2011 [Member] Starter | Points: 25

Up
0
Down
Thanks for your reply Vuyiswamb,
Currently i am having IIS V5.1 in my laptop

Now i have two questions:
Let me know whether my existing applications will affect or not - If i install IIS7 ?
and get me a link to download IIS7 suitable for my laptop configuration.

NOTE: I have lot of classic asp and vb in my lap - if anything affect for those application.
i like to quite installing IIS7. :-)

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 9/18/2011 [Member] [MVP] [Administrator] NotApplicable | Points: 25

Up
0
Down
To my knowledge there can be only one IIS in a machine. So if you uninstall the IIS 5.1(never used it before). and install IIS 7 , it will not affect others, but you will need to do some little twiks.

Thank you for posting at Dotnetfunda
[Administrator]

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Thiru on: 9/18/2011 [Member] Starter | Points: 25

Up
0
Down
If so, i will take care of this step little bit later.
because i am having 2project to be deliver in 3days.

after that i will take care. Thanks Vuiswa

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 9/18/2011 [Member] [MVP] [Administrator] NotApplicable | Points: 25

Up
0
Down
:) i m always here

Thank you for posting at Dotnetfunda
[Administrator]

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Thiru on: 9/18/2011 [Member] Starter | Points: 25

Up
0
Down
Yes I know myfriend and dotnet Administrator.
Thanks for you support and for dotnet funda :-)

Thiru, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response