AutoCompleteExtender in gridview

Posted by Sld5358 under ASP.NET AJAX on 9/23/2009 | Views : 3321 | Status : [Member] | Replies : 1
I have a master detail gridview. In the detail gridview I have a text box with an autocomplete extender. The search function works fine. However, when the listbox comes up with the matches the list goes behind the cells in the gridview. I have tried css with zindex set to 10 and this does not help. I want the listbox to sit on top of the gridview like a normal dropdown list would.
Any suggestions?


Posted by: Rtpharry on: 9/25/2009 [Member] [MVP] Bronze

Its a tricky one to fix! Is there a demo online that we can click about with and investigate your css settings?

When I read it I immediately thought of the various border collapse settings that come with tables... I dont know if this would affect it. Or if you have overflow:hidden set on your cell?

If you cant give us an online demo to play with then perhaps try disabling all of your css.

If that works then put blocks back in until it breaks and then figure out which individual rule in that block is breaking it.

Sld5358, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response