Strange Issues on ASP.NET App

Posted by Vuyiswamb under ASP.NET on 11/12/2009 | Views : 1274 | Status : [Member] [MVP] [Administrator] | Replies : 8
Good Day All

I have a ASP.NET app. There is a button one of the pages. I have placed a Break point in the Click event and when i click the Button it does not even go to the Break Point it shows this

http://www.tiyaneproperties.co.za/SSIS/Strange.jpg


Thanks

Thank you for posting at Dotnetfunda
[Administrator]



Responses

Posted by: SheoNarayan on: 11/12/2009 [Administrator] HonoraryPlatinum

Up
0
Down
There are few possibilities based on how you are trying to debug.

1. If you are attaching the aspnet_wp.exe manually from Debug menu, make sure that you are building all projects in that solution and at last build the web application/website project.

2. Sometimes, that doesn't solve the problem so you may try closing the IDE and open your solution again.

3. If you hitting F5, sometimes this also doesn't detect the break points, so the again before hitting the F5, ensure that you can build all the related projects and then hit F5.

4. Check that the OnlClick event name is same as the event name you have written in the .aspx.cs page (exact name with same upper-lower case).

Please let me know if above solve your problem.

Thank you.

Regards,
Sheo Narayan
http://www.dotnetfunda.com

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 11/12/2009 [Member] [MVP] [Administrator] NotApplicable

Up
0
Down
in other machines it works well. am not sure what is wrong. This can be a Browser issue. But it does not say much form the info it gave me.

Thank you for posting at Dotnetfunda
[Administrator]

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: SheoNarayan on: 11/12/2009 [Administrator] HonoraryPlatinum

Up
0
Down
Hmmm... I am not sure as the screenshot you have provided is of IE (7) and IE is the default browser Visual Studio consider for the debugging.

Did you try above 4 points and still you are not getting the breakpoint in the debug mode?

Thanks

Regards,
Sheo Narayan
http://www.dotnetfunda.com

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 11/12/2009 [Member] [MVP] [Administrator] NotApplicable

Up
0
Down
i tried but nope it did not work

Thank you for posting at Dotnetfunda
[Administrator]

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Lakhangarg on: 11/12/2009 [Member] [Moderator] Silver

Up
0
Down
Hi -

i also come across the same issue some times. and there is no permanent solution i found for it.
what you can do is:

(1) CLose and Reopen IDE.
(2) Restart IIS

or

(1) Import/ Export Setting and set as Default Setting.

Check these two tricks.. may be this will resolve your issue. it works for me.

Thanks & Regards
Lakhan Pal garg

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 11/12/2009 [Member] [MVP] [Administrator] NotApplicable

Up
0
Down
Nope it does not work.

thanks For your reply Lakhangarg

Thank you for posting at Dotnetfunda
[Administrator]

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Virendradugar on: 11/12/2009 [Member] [MVP] Silver

Up
0
Down
Hi Vuyiswamb,

Clear the temporary file for your website from this location.

"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files "

And then restart IIS.

Let me know if it works.

Thanks,
Virendra Dugar

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Vuyiswamb on: 11/12/2009 [Member] [MVP] [Administrator] NotApplicable

Up
0
Down
That is the First thing i did when i got this problem. I have resolved the Problems. The File that i wanted to import when that button is Clicked was too big. So i have resolved this by adding the Following entry in the web config in the System.web Section

<httpRuntime maxRequestLength="102400" /> 


Thank you guys for your help. I sometimes get lost too and i always count on you to help me. i cant know everything.

Thanks again for being part of Dotnetfunda

Vuyiswa Maseko

Thank you for posting at Dotnetfunda
[Administrator]

Vuyiswamb, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response