Solution files in VS2008

Posted by Nishithraj under Regular Expressions on 2/22/2010 | Views : 4846 | Status : [Member] | Replies : 6
Usually in previous versions we can find the solution files of a website project in the same folder that we specify(creation time).

But in visual studio, it seems like the solution file stores in different path like as follows

C:\Documents and Settings\nishithrajn\My Documents\Visual Studio 2008\Projects\WebSite2


And the rest of the files stores in the path that we specify. So, it is very difficutl to copy from one system to another.

Why it's behaving like this? Any way is there to resolve this issue?

Mark this as answer, if it is.....

With regards
Nishithraj Narayanan



Responses

Posted by: Vuyiswamb on: 2/22/2010 [Member] [MVP] [Administrator] NotApplicable

Up
0
Down
When you create a new Project in VS , it create a new Folder with the same name as your project in

C:\Documents and Settings\vuyiswa\My Documents\Visual Studio 2005\Projects\


only if you allowed it to save some files that are related to your solution. It happened to me. When you Create a Solution with Multiple Projects you must make sure it saves it into the correct Folder, be careful because the Directory that it creates in the same name as your real project name directory and this might lure you to think its the correct one. Better browse and make sure you are using the correct one. that is the way it works unfortunately


Thank you for posting at Dotnetfunda
[Administrator]

Nishithraj, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Abhi2434 on: 2/22/2010 [Member] [Microsoft_MVP] [MVP] Silver

Up
0
Down
I always like to create Web Application projects. Websites generally keep lots of data hidden to us. The designer is stored in Windows directory inside Temporary Asp.NEt files, Solution is stored in WebSites section. etc.

If you are building an ASP.NET Web Application project, everything will be stored according to your specification from the Dialog box.

Also after you add any WebForm, always right click on that and Convert to Web Application. This will make your webform to generate Designer in same location.

Cheers.


www.abhisheksur.com

Nishithraj, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Nishithraj on: 2/24/2010 [Member] Bronze

Up
0
Down
Yes I agree. But there might be some workarounds to resolve this...

Mark this as answer, if it is.....

With regards
Nishithraj Narayanan

Nishithraj, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Gttejas on: 3/19/2010 [Member] Starter

Up
0
Down
Hi,

Yes, There is a workaround to change this default behaviour.The reason for this default behaviour is website project
does not require solution file.

1) Create a Blank Solution
To create an ASP.NET Web Application, start by explicitly creating a Visual Studio Solution (.sln) file and then add your Web site and any supplementary projects you might need, such as class libraries. In the following steps, you create your solutions beneath a top level C:\DevProjects folder

2)On the File menu, point to New and then click* Project*.
Expand Other Project Types and select Visual Studio Solutions.
Select Blank Solution.
Name your solution MyWebAppSln.
Set the Location to C:\DevProjects and then click OK.

2) Create New website project under this solution.

Regards,
Tejas Trivedi


Nishithraj, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Pmulimani on: 2/13/2012 [Member] Starter | Points: 25

Up
0
Down
Try Like that

Go to Tools ==> Options ==> (From the left pane) Projects and Solutions ==> General ==> (check the checkbox) Always show solution

it might solve your problem.

Nishithraj, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response