WCF service enable with SSL

Posted by Sushilkumar.Sush under WCF on 8/17/2015 | Points: 10 | Views : 1112 | Status : [Member] | Replies : 2
hi.

When i am using WCF in SSL while access in WCFTESTCLIENT getting following Warning.

You are about to send information over the network. Insecure bindings or malicious services could allow private information to be viewed by others. Do not try to invoke services you do not trust, and use a secure binding if you are transmitting information you do not want others to see.

Please help on above issue

thanks in advance

Sushilkumar Shinde


Responses

Posted by: Sheonarayan on: 8/18/2015 [Administrator] HonoraryPlatinum | Points: 25

Up
0
Down
This error should go on live environment, perhaps you are not using trusted SSL connection.

If that doesn't solve the problem, read this article that details security considerations while transmitting data https://msdn.microsoft.com/en-us/library/ms733135.aspx.

Thanks

Regards,
Sheo Narayan
http://www.dotnetfunda.com

Sushilkumar.Sush, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Sushilkumar.Sush on: 8/18/2015 [Member] Starter | Points: 25

Up
0
Down
Hello sir ,

Thanks for the reply..

i have already go throw the above link. i have applied the setting which is mention in the article.
i have using the SSL connection setting in Web.config and IIS level but when i am access the my WCF EndPoint using WCFTESTCLIENT that time i have face the issue.

I didn't getting what i have did any wrong.

Any other suggestion .Please help me.

Thanks.
Sushilkumar Shinde

Sushilkumar Shinde

Sushilkumar.Sush, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response