AutoComplete option in SQL Server 2008 [Resolved]

Posted by Amatya under Sql Server on 2/16/2016 | Points: 10 | Views : 203 | Status : [Member] | Replies : 3
What to do to have AutoComplete option in SQL Server 2008, any settings in SQL Server or any software option?

Feel free to share informations 9731764134
Thanks



Responses

Posted by: Rajnilari2015 on: 2/16/2016 [Member] [Microsoft_MVP] [MVP] Platinum | Points: 50

Up
0
Down

Resolved
@Amatya Sir,

From SSMS 2008 onwards, we have the IntelliSense feature.It provides internal metadata and a list of available objects and properties while writing T-SQL queries.

The below are the steps to follow for the same

Step 1: Go to Tools -> Options -> Text Editor -> Transact-SQL -> IntelliSense and make sure the Enable IntelliSense checkbox is checked

Step 2: To verify that it is enabled, go to the Query menu and check that IntelliSense is enabled. Alternatively, the short cut key for the same is Ctrl+Q, Ctrl+I

Alternatively, if your are looking for some 3rd party effective tool, you can try with

a) dbForge SQL Complete (https://www.devart.com/dbforge/sql/sqlcomplete/ ) . A free edition is also available.

b) The SQL Developer Suite from RedGate(http://www.red-gate.com/products/sql-development/sql-developer-suite/ ). A 14days trial version is available.

Hope this helps

--
Thanks & Regards,
RNA Team

Amatya, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: A2H on: 2/16/2016 [Member] [MVP] Silver | Points: 25

Up
0
Down
If you are ok with using Third Party Tools then you can take a look Apex SQLComplete.

http://www.apexsql.com/sql_tools_complete.aspx

Thanks,
A2H
My Blog

Amatya, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Amatya on: 2/17/2016 [Member] Bronze | Points: 25

Up
0
Down
Dear Rajnilari2015.. Step 1 is ok.. but where i can get Query menu in SQL Server Management Studio 2008

The scenario is when i am typing select statement... after typing se it should show select and set option in the Query window...


Feel free to share informations 9731764134
Thanks

Amatya, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response