RFC_ERROR_SYSTEM_FAILURE with SAP ECC 6 Unicode [Resolved]

Posted by Ajaydabhade under BizTalk Server on 10/11/2010 | Points: 10 | Views : 13853 | Status : [Member] | Replies : 2
Hi All,
I am using BizTalk 2006 R2, Microsoft BizTalk Adapter v2.0 for mySAP Business Suite SP1 & SQL Server 2005 as a Database server.
In past we developed Orchestrations which were communicating with SAP version 4.7. Currently SAP has been upgraded in ECC 6(Unicode) system.
I have configured new Send Port on server. Orchestration was able to communicate with SAP ECC 6.0 (Non- Unicode) system but while trying to connect with SAP ECC 6.0 (Unicode) I am getting error.
A message sent to adapter "SAP" on send port "ECC 6 SendPort" with URI "sap://AS:***.**.***.***/**/***/" is suspended.
Error details: RFC_ERROR_SYSTEM_FAILURE
I also installed RFC SDK 7.10 Unicode version an also set environment variables for SAP GUI tracing. Now I can execute RFC which returns CHAR value but in case of NUM data type, I am getting following error in trace file,

T:4012 Error in program 'BTSNTSvc':
>> ERROR: Import parameter length difference detected.
Read length: 7. Expected length: 0. Type: 2.

T:4012 Error in program 'BTSNTSvc': <* RfcReceive [2] : returns 19:RFC_INVALID_PARAMETER
T:4012 Error in program 'BTSNTSvc': <* RfcCallReceive [2] : returns 19:RFC_INVALID_PARAMETER
T:4012 Error in program 'BTSNTSvc': <* RfcCleanupContext [2] : returns 18:RFC_INVALID_HANDLE
T:4012 Error in program 'BTSNTSvc': <* RfcCleanupContext [2] : returns 18:RFC_INVALID_HANDLE


Thanks in advance.

AJAY DABHADE
(MCPD, MCTS)
"Plan your work, work on your plan and your plan will work."



Responses

Posted by: Lalji_mer on: 10/26/2010 [Member] Bronze | Points: 50

Up
0
Down

Resolved
check this link

http://www.go4answers.com/Example/rfc_error_system_failure-sap-ecc-6-135204.aspx

LP MER

Ajaydabhade, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Oliviajones on: 7/31/2013 [Member] Starter | Points: 25

Up
0
Down
Check this:
1. Version of SAPGUI you install? try install SAP GUI 710 or 720 If you only install the RFC SDK
2. Do you have a librfc32.dll installed on the system?
3. Look inside SAP in transaction SM21 if you see some error messages. contact SAP expert for this and choose right application server with SM51
http://www.athenainfotech.co.uk/managed-b2b-services


Ajaydabhade, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response