ALTER DATABASE '' SET ENABLE_BROKER taking loong time to execute

Posted by SheoNarayan under Error and Solution on 4/9/2011 | Points: 10 | Views : 6491 | Status : [Administrator] | Replies : 1

Problem:
Executing Enable_Broker command on the database to enabl SQL SErvice Broker for Push SQL Cache dependencies takes looonnng time. Keep executing for hours and hours

ALTER DATABASE DemoDatabase SET ENABLE_BROKER


Solution:
Make sure that you are closing all instances of the database on which you are trying to enable broker. Better to disconnect the database server and connect again and then fire above SQL statement. The SET ENABLE_BROKER needs an exclusive lock on the database.

Hope this helps.

Regards,
Sheo Narayan
http://www.dotnetfunda.com



Responses

Posted by: Karthikanbarasan on: 4/11/2011 [Member] [Moderator] [Microsoft_MVP] [MVP] Silver | Points: 25

Up
0
Down
Thanks Sheo!!!

Thanks
Karthik
www.f5Debug.net

SheoNarayan, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response