IE11 does not load CSS Styles

Posted by Kuku under ASP.NET on 5/22/2014 | Points: 10 | Views : 1979 | Status : [Member] | Replies : 2
Hi all,

I deployed an website on a server running IIS 7 and for some reason my IE11 is returning my site with a long guid on the url.

I deployed the same website on 2 other different servers running IIS7 and when i view the website in IE11 it is coming alright.

I have tried changing my script name thinking that it is being cached but still it has not worked. I also compared the settings on IIS and they are all the same.

Has anyone else encountered such a problem or its only me, also what could be the possible solution to this.

Thanks for responses.


Posted by: Sheonarayan on: 5/23/2014 [Administrator] HonoraryPlatinum | Points: 25

Long guid generally comes when cookie is disabled in the browser. So check your browser setting for cookies however this may not be the case as the same website from other server is working fine.

The other case might be that session settings might be set in the web.config/machine.config file as cookieless that is forcing to maintain the session using url.

Hope this will give some clue.

Sheo Narayan

Kuku, if this helps please login to Mark As Answer. | Alert Moderator

Posted by: Kuku on: 5/23/2014 [Member] Starter | Points: 25

Hi, Thanks for your responses.
I added cookieless="false" to my webconfig and it is as shown below:

<sessionState customProvider="DefaultSessionProvider" mode="InProc" cookieless="false">
<add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" />

The guid does not come up and if i change it to cookieless="true" the long guid comes up. When i viewed the source of my page, i notice that the long guid is coming up on my path to the folder as well as shown below.

<link href="/Content/Site.css" rel="stylesheet" /><link href="favicon.ico" rel="shortcut icon" type="image/x-icon" />
<script src="/(F(hAPXXS-chHBD7f38z8lkTah-8oa3DwDpe-JGjigqkPTQVu1Lrc_IBVD6EJKVCUvxybo0rRCS5QzuhxkDd-ZRrpKzdKnIbIENp0xpOuenT6-zo1Eyh_XjqFF-m0izAt36Tpgxlf1JutiQDE8RIIcjjiAlZMer3YcpP6WjRQ0B6QbBVt1zq1AE9ylqISHTpLnQ0))/Scripts/modernizr-2.6.2.js"></script>
<script src="/(F(hAPXXS-chHBD7f38z8lkTah-8oa3DwDpe-JGjigqkPTQVu1Lrc_IBVD6EJKVCUvxybo0rRCS5QzuhxkDd-ZRrpKzdKnIbIENp0xpOuenT6-zo1Eyh_XjqFF-m0izAt36Tpgxlf1JutiQDE8RIIcjjiAlZMer3YcpP6WjRQ0B6QbBVt1zq1AE9ylqISHTpLnQ0))/Scripts/jquery-1.8.2.js"></script>

Funny thing is this guid keeps changing each time i reload the website.

Could there be something on the server which i have not checked?


Kuku, if this helps please login to Mark As Answer. | Alert Moderator

Login to post response